A repository of tips and tricks (in both English and French) curated by Mirego’s engineering team.
  • ember
  • javascript

Utiliser ember-cli-code-coverage avec nyc

Si jamais vous désirez utiliser ember-cli-code-coverage avec l’outil nyc pour votre projet Ember.JS, sachez que les rapports générés avec les versions de la branche 1.x de ember-cli-code-coverage ne sont pas 100% compatibles avec nyc.

Pour corriger la situation, il suffit de supprimer le fichier coverage-summary.json du répertoire du rapport de couverture et les commandes de nyc (par exemple, la commande npx nyc check-coverage) fonctionneront! :wink:

Référence: https://github.com/kategengler/ember-cli-code-coverage/pull/173#issuecomment-381274578